You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-libs/socket_wrapper/socket_wrapper-1.3.2.ebuild

28 lines
629 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CMAKE_ECLASS=cmake
inherit cmake-multilib
DESCRIPTION="A library passing all socket communications through unix sockets"
HOMEPAGE="https://cwrap.org/socket_wrapper.html"
SRC_URI="https://ftp.samba.org/pub/cwrap/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ppc ppc64 ~sparc ~x86"
IUSE="test"
RESTRICT="!test? ( test )"
BDEPEND="test? ( >=dev-util/cmocka-1.1.0 )"
src_configure() {
local mycmakeargs=(
-DUNIT_TESTING=$(usex test ON OFF)
)
cmake-multilib_src_configure
}