You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-mail/altermime/altermime-0.3.11.ebuild

31 lines
609 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit toolchain-funcs
DESCRIPTION="alterMIME is a small program which is used to alter your mime-encoded mailpacks"
HOMEPAGE="https://pldaniels.com/altermime/"
SRC_URI="https://www.pldaniels.com/altermime/${P}.tar.gz"
KEYWORDS="amd64 ppc x86"
LICENSE="Sendmail"
SLOT="0"
IUSE=""
PATCHES=(
"${FILESDIR}"/${PN}-0.3.10-MIME_headers-overflow.patch
"${FILESDIR}"/${P}-respect-flags.patch
)
src_compile() {
emake CC="$(tc-getCC)"
}
src_install() {
dobin altermime
dodoc CHANGELOG README
}