You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-mail/libdbx/libdbx-1.0.3.ebuild

35 lines
674 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit toolchain-funcs
MY_PN="libdbx"
MYFILE="${MY_PN}_${PV}.tgz"
DESCRIPTION="Tools and library for reading Outlook Express mailboxes (.dbx format)"
HOMEPAGE="https://sourceforge.net/projects/ol2mbox"
SRC_URI="mirror://sourceforge/ol2mbox/${MYFILE}"
S="${WORKDIR}/${MY_PN}_${PV}"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 x86"
PATCHES=(
"${FILESDIR}"/bad_c.patch
)
src_prepare() {
default
sed -i -e 's/-g/$(CFLAGS) $(LDFLAGS)/;s|gcc|$(CC)|g' Makefile || die
tc-export CC
}
src_install() {
dobin readoe readdbx
dodoc README* AUTHORS FILE-FORMAT
}