You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-mail/mailbase/mailbase-1.5-r2.ebuild

48 lines
937 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit pam
DESCRIPTION="MTA layout package"
SRC_URI=""
HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~s390 sparc x86"
IUSE="pam"
RDEPEND="
acct-group/mail
acct-user/mail
acct-user/postmaster
pam? ( sys-libs/pam )
!<net-mail/metamail-2.7.53.3-r2"
S=${WORKDIR}
src_install() {
dodir /etc/mail
insinto /etc/mail
doins "${FILESDIR}"/aliases
insinto /etc
doins "${FILESDIR}"/mailcap
doman "${FILESDIR}"/mailcap.5
dosym spool/mail /var/mail
if use pam ; then
newpamd "${FILESDIR}"/common-pamd-include pop
newpamd "${FILESDIR}"/common-pamd-include imap
local p
for p in pop3 pop3s pops ; do
dosym pop /etc/pam.d/${p}
done
for p in imap4 imap4s imaps ; do
dosym imap /etc/pam.d/${p}
done
fi
}