You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-mail/mailman/mailman-3.3.1-r1.ebuild

45 lines
1.4 KiB

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
PYTHON_COMPAT=( python3_7 )
inherit distutils-r1
DESCRIPTION="Mailman -- the GNU mailing list manager"
HOMEPAGE="https://www.list.org"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="GPL-3+"
SLOT="3"
#KEYWORDS="~amd64 ~ppc ~x86"
KEYWORDS="" # nothing til this is finished
IUSE=""
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
RDEPEND="
>=dev-python/aiosmtpd-1.1[${PYTHON_USEDEP}]
dev-python/alembic[${PYTHON_USEDEP}]
dev-python/atpublic[${PYTHON_USEDEP}]
>=dev-python/authheaders-0.13.0[${PYTHON_USEDEP}]
>=dev-python/authres-1.0.1[${PYTHON_USEDEP}]
>=dev-python/click-7.0[${PYTHON_USEDEP}]
>=dev-python/dnspython-1.14.0[${PYTHON_USEDEP}]
>=dev-python/falcon-2.0.0[${PYTHON_USEDEP}]
dev-python/flufl-bounce[${PYTHON_USEDEP}]
>=dev-python/flufl-i18n-2.0.1[${PYTHON_USEDEP}]
>=dev-python/flufl-lock-3.1[${PYTHON_USEDEP}]
>=dev-python/importlib_resources-1.5.0[${PYTHON_USEDEP}]
www-servers/gunicorn[${PYTHON_USEDEP}]
dev-python/lazr-config[${PYTHON_USEDEP}]
>=dev-python/python-dateutil-2.0[${PYTHON_USEDEP}]
dev-python/passlib[${PYTHON_USEDEP}]
dev-python/requests[${PYTHON_USEDEP}]
>=dev-python/sqlalchemy-1.2.3[${PYTHON_USEDEP}]
dev-python/zope-component[${PYTHON_USEDEP}]
dev-python/zope-configuration[${PYTHON_USEDEP}]
dev-python/zope-event[${PYTHON_USEDEP}]
>=dev-python/zope-interface-5.0[${PYTHON_USEDEP}]
"