You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-mail/postorius/postorius-1.3.3.ebuild

33 lines
805 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
PYTHON_COMPAT=( python3_{7,8} )
inherit distutils-r1
DESCRIPTION="A web user interface for GNU Mailman 3"
HOMEPAGE="https://www.list.org"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="~amd64"
IUSE="test"
RESTRICT="!test? ( test )"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
RDEPEND="net-mail/django-mailman3[${PYTHON_USEDEP}]
dev-python/django[${PYTHON_USEDEP}]
net-mail/mailmanclient[${PYTHON_USEDEP}]
dev-python/readme_renderer[${PYTHON_USEDEP}]
test? (
dev-python/mock[${PYTHON_USEDEP}]
dev-python/vcrpy[${PYTHON_USEDEP}]
dev-python/beautifulsoup[${PYTHON_USEDEP}]
dev-python/isort[${PYTHON_USEDEP}]
)"
DOCS=( README.rst )