You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-misc/connman-gtk/connman-gtk-1.1.1-r1.ebuild

54 lines
927 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit autotools gnome2-utils
DESCRIPTION="GTK GUI for Connman"
HOMEPAGE="https://github.com/jgke/connman-gtk"
SRC_URI="https://github.com/jgke/connman-gtk/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE="openconnect"
CDEPEND="
>=dev-libs/glib-2.0:2
>=x11-libs/gtk+-3.10:3
openconnect? ( >=net-vpn/openconnect-5.99 )
"
RDEPEND="${CDEPEND}
net-misc/connman
"
DEPEND="${CDEOEND}
>=dev-util/intltool-0.35.0
sys-devel/gettext
virtual/pkgconfig
"
src_prepare() {
default
sed -i -e '/^Categories/ s/$/;/' connman-gtk.desktop.in || die
eautoreconf
}
src_configure() {
econf \
--disable-schemas-compile \
$(use_with openconnect)
}
pkg_preinst() {
gnome2_schemas_savelist
}
pkg_postinst() {
gnome2_schemas_update
}
pkg_postrm() {
gnome2_schemas_update
}