You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-misc/grive/grive-0.5.1-r1.ebuild

37 lines
787 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit cmake
if [[ ${PV} = *9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/vitalif/${PN}2.git"
else
inherit vcs-snapshot
SRC_URI="https://github.com/vitalif/${PN}2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
fi
DESCRIPTION="An open source Linux client for Google Drive"
HOMEPAGE="https://github.com/vitalif/grive2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
RDEPEND="
dev-libs/boost:=
dev-libs/expat
>=dev-libs/json-c-0.11-r1:=
dev-libs/libgcrypt:0=
dev-libs/yajl
|| ( net-misc/curl[curl_ssl_openssl] net-misc/curl[curl_ssl_gnutls] )
sys-libs/binutils-libs:0=
sys-libs/glibc
"
DEPEND="${RDEPEND}"
PATCHES=( "${FILESDIR}/299.patch" )