You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-misc/kafkacat/kafkacat-1.5.0.ebuild

33 lines
669 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
inherit toolchain-funcs
DESCRIPTION="Generic command line non-JVM Apache Kafka producer and consumer"
HOMEPAGE="https://github.com/edenhill/kafkacat"
SRC_URI="https://github.com/edenhill/kafkacat/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="BSD-2"
SLOT="0"
KEYWORDS="amd64"
IUSE="+avro +json"
DEPEND=">=dev-libs/librdkafka-0.9.4
avro? (
dev-libs/avro-c
dev-libs/libserdes
)
json? ( dev-libs/yajl )"
RDEPEND="${DEPEND}"
src_configure() {
econf $(use_enable avro) $(use_enable json) --cc=$(tc-getCC)
}
src_install() {
default
doman ${PN}.1
}