You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-misc/pyhoca-cli/pyhoca-cli-0.6.1.2.ebuild

37 lines
800 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
PYTHON_COMPAT=( python3_{7..9} )
inherit distutils-r1
DESCRIPTION="X2Go command line client"
HOMEPAGE="http://www.x2go.org"
SRC_URI="http://code.x2go.org/releases/source/${PN}/${P}.tar.gz"
LICENSE="AGPL-3+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
RDEPEND="
dev-python/setproctitle[${PYTHON_USEDEP}]
>=net-misc/python-x2go-0.6.1.1[${PYTHON_USEDEP}]"
python_prepare_all() {
# we don't need setuptools at runtime
sed -i -e '/install_requires/d' setup.py || die
distutils-r1_python_prepare_all
}
python_install() {
distutils-r1_python_install
python_doscript ${PN}
}
python_install_all() {
distutils-r1_python_install_all
doman man/man1/*
find "${ED}" -name '*.pth' -delete || die
}