You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-misc/radvd/radvd-2.18.ebuild

70 lines
1.5 KiB

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
inherit systemd user readme.gentoo-r1
DESCRIPTION="Linux IPv6 Router Advertisement Daemon"
HOMEPAGE="http://v6web.litech.org/radvd/"
SRC_URI="http://v6web.litech.org/radvd/dist/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 arm arm64 ~hppa ppc ~ppc64 sparc x86"
IUSE="kernel_FreeBSD selinux test"
RESTRICT="!test? ( test )"
CDEPEND="dev-libs/libdaemon"
DEPEND="${CDEPEND}
sys-devel/bison
sys-devel/flex
virtual/pkgconfig
test? ( dev-libs/check )"
RDEPEND="${CDEPEND}
selinux? ( sec-policy/selinux-radvd )
"
DOCS=( CHANGES README TODO radvd.conf.example )
PATCHES=(
)
pkg_setup() {
enewgroup radvd
enewuser radvd -1 -1 /dev/null radvd
}
src_configure() {
econf --with-pidfile=/run/radvd/radvd.pid \
--with-systemdsystemunitdir=no \
$(use_with test check)
}
src_install() {
default
insinto /usr/share/doc/${PF}/html
doins INTRO.html
newinitd "${FILESDIR}"/${PN}-2.15.init ${PN}
newconfd "${FILESDIR}"/${PN}.conf ${PN}
systemd_dounit "${FILESDIR}"/${PN}.service
if use kernel_FreeBSD ; then
sed -i -e \
's/^SYSCTL_FORWARD=.*$/SYSCTL_FORWARD=net.inet6.ip6.forwarding/g' \
"${D}"/etc/init.d/${PN} || die
fi
readme.gentoo_create_doc
}
DISABLE_AUTOFORMATTING=1
DOC_CONTENTS="Please create a configuration file ${ROOT}etc/radvd.conf.
See ${ROOT}usr/share/doc/${PF} for an example.
grsecurity users should allow a specific group to read /proc
and add the radvd user to that group, otherwise radvd may
segfault on startup."