You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-misc/rwhoisd/rwhoisd-1.5.9.6-r1.ebuild

47 lines
829 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit flag-o-matic
DESCRIPTION="ARIN rwhois daemon"
HOMEPAGE="http://projects.arin.net/rwhois/"
SRC_URI="https://github.com/arineng/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/${P}/${PN}"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
DEPEND="
sys-devel/flex
virtual/yacc
"
RDEPEND="
acct-group/rwhoisd
acct-user/rwhoisd
"
src_compile() {
append-cflags -DNEW_STYLE_BIN_SORT
emake -C common
emake -C regexp
emake -C mkdb
default
}
src_install() {
default
doinitd "${FILESDIR}"/rwhoisd
newconfd "${FILESDIR}"/rwhoisd.conf rwhoisd
}
pkg_postinst() {
einfo "Please make sure to set the userid in rwhoisd.conf to rwhoisd."
einfo "It is highly inadvisable to run rwhoisd as root."
}