You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-misc/seafile/seafile-8.0.1.ebuild

49 lines
1.1 KiB

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
PYTHON_COMPAT=(python3_{7,8,9})
WANT_AUTOMAKE=1.16
inherit autotools python-single-r1 vala
DESCRIPTION="File syncing and sharing software with file encryption and group sharing"
HOMEPAGE="https://www.seafile.com/ https://github.com/haiwen/seafile/"
SRC_URI="https://github.com/haiwen/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-2+-with-openssl-exception"
SLOT="0"
KEYWORDS="~amd64 ~x86"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RDEPEND="${PYTHON_DEPS}
$(python_gen_cond_dep '
dev-python/future[${PYTHON_MULTI_USEDEP}]
')
dev-libs/openssl:=
dev-db/sqlite:3
dev-libs/glib:2
dev-libs/jansson
dev-libs/libevent
net-libs/libsearpc[${PYTHON_SINGLE_USEDEP}]
net-misc/curl
sys-libs/zlib"
DEPEND="${RDEPEND}
$(vala_depend)"
src_prepare() {
default
sed -i -e 's/valac /${VALAC} /' lib/Makefile.am || die
eautoreconf
vala_src_prepare
}
src_install() {
default
# Remove unnecessary .la files, as recommended by ltprune.eclass
find "${ED}" -name '*.la' -o -name '*.a' -delete || die
python_fix_shebang "${ED}"/usr/bin
}