You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-misc/spread/spread-4.4.1.ebuild

39 lines
701 B

# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
inherit user
MY_PN="spread-src"
DESCRIPTION="Distributed network messaging system"
HOMEPAGE="http://www.spread.org"
SRC_URI="mirror://gentoo/${MY_PN}-${PV}.tar.gz"
LICENSE="Spread-1.0"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE=""
DEPEND=""
RDEPEND="${DEPEND}"
S="${WORKDIR}/${MY_PN}-${PV}"
pkg_setup() {
enewuser spread
enewgroup spread
}
src_prepare() {
default
# don't strip binaries
sed -i -e 's/0755 -s/0755/g' daemon/Makefile.in examples/Makefile.in
}
src_install() {
emake DESTDIR="${D}" docdir="/usr/share/doc/${PF}" install
newinitd "${FILESDIR}"/spread.init.d spread
}