You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-p2p/torrentinfo/torrentinfo-1.8.6-r2.ebuild

30 lines
784 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
PYTHON_COMPAT=( pypy3 python3_{7,8,9} )
# The package uses distutils
DISTUTILS_USE_SETUPTOOLS=no
inherit distutils-r1
DESCRIPTION="A torrent file parser"
HOMEPAGE="https://github.com/Fuuzetsu/torrentinfo"
SRC_URI="https://github.com/Fuuzetsu/torrentinfo/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE="test"
RESTRICT="!test? ( test )"
BDEPEND="test? ( dev-python/nose[${PYTHON_USEDEP}] )"
PATCHES=( "${FILESDIR}/${P}-fix-tests.patch" )
# distutils_enable_tests nose doesn't work here,
# probably because the test file has a non-standard name
python_test() {
nosetests test/tests.py || die "tests failed with ${EPYTHON}"
}