You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-print/cups-pdf/cups-pdf-3.0.1-r1.ebuild

47 lines
899 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
inherit toolchain-funcs
DESCRIPTION="Provides a virtual printer for CUPS to produce PDF files"
HOMEPAGE="https://www.cups-pdf.de/"
SRC_URI="https://www.cups-pdf.de/src/${PN}_${PV/_}.tar.gz"
S=${WORKDIR}/${PN}-${PV/_}
LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="amd64 ~arm ppc ~ppc64 x86"
IUSE="+ppds"
RDEPEND="
net-print/cups
<app-text/ghostscript-gpl-9.54
"
DEPEND="${RDEPEND}"
src_compile() {
pushd src >/dev/null
$(tc-getCC) ${LDFLAGS} ${CFLAGS} ${PN}.c -o ${PN} -lcups || die
popd >/dev/null
}
src_install() {
exeinto /usr/libexec/cups/backend
exeopts -m0700
doexe src/cups-pdf
insinto /etc/cups
doins extra/cups-pdf.conf
insinto /usr/share/cups/model
if use ppds; then
doins extra/CUPS-PDF_opt.ppd
else
doins extra/CUPS-PDF_noopt.ppd
fi
dodoc ChangeLog README
}