You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-print/poster/poster-20060221-r3.ebuild

32 lines
677 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
inherit toolchain-funcs
DESCRIPTION="Small utility for making a poster from an EPS file or a one-page PS document"
SRC_URI="mirror://kde/printing/${P}.tar.bz2"
HOMEPAGE="https://printing.kde.org/downloads"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~ppc x86"
IUSE=""
PATCHES=(
"${FILESDIR}/${P}-fix_gs_crash.patch"
"${FILESDIR}/${P}-fix_duplicate_DocumentMedia.patch"
"${FILESDIR}/${P}-fix_cutmarks.patch"
)
src_compile() {
$(tc-getCC) ${CFLAGS} ${LDFLAGS} ${PN}.c -lm -o ${PN} || die
}
src_install() {
dobin ${PN}
doman ${PN}.1
dodoc README ChangeLog
}