You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-vpn/isatapd/isatapd-0.9.7-r2.ebuild

40 lines
943 B

# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit linux-info systemd
DESCRIPTION="Creates and maintains an ISATAP tunnel (rfc5214)"
HOMEPAGE="http://www.saschahlusiak.de/linux/isatap.htm"
SRC_URI="http://www.saschahlusiak.de/linux/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE=""
DEPEND=""
RDEPEND=""
CONFIG_CHECK="~TUN"
ERROR_TUN="CONFIG_TUN is needed for isatapd to work"
PATCHES=( "${FILESDIR}"/${PN}-linux-4.8.patch )
src_prepare() {
default
sed -e '/^opts/s:opts:extra_started_commands:' \
-i openrc/isatapd.init.d || die
sed -e 's:#!/sbin/runscript:#!/sbin/openrc-run:' \
-i openrc/isatapd.init.d || die
}
src_install() {
default
newinitd openrc/isatapd.init.d isatapd
newconfd openrc/isatapd.conf.d isatapd
systemd_newunit "${FILESDIR}"/${PN}.service-r2 ${PN}.service
systemd_install_serviced "${FILESDIR}"/${PN}.service.conf
}