You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-wireless/b43-fwcutter/b43-fwcutter-019.ebuild

36 lines
725 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
inherit toolchain-funcs
DESCRIPTION="Firmware Tool for Broadcom 43xx based wireless network devices
using the mac80211 wireless stack"
HOMEPAGE="https://bues.ch/b43/fwcutter/"
SRC_URI="https://bues.ch/b43/fwcutter/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~arm64 ppc ppc64 x86"
IUSE=""
src_compile() {
MAKEOPTS+=" V=1"
emake CC="$(tc-getCC)"
}
src_install() {
# Install fwcutter
dobin ${PN}
doman ${PN}.1
dodoc README
}
pkg_postinst() {
echo
einfo "Firmware may be downloaded from http://linuxwireless.org."
einfo "This version of fwcutter works with all b43 driver versions."
echo
}