You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-wireless/crackle/crackle-9999.ebuild

29 lines
626 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
DESCRIPTION="Crackle cracks BLE Encryption (AKA Bluetooth Smart)"
HOMEPAGE="http://lacklustre.net/projects/crackle/"
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://github.com/mikeryan/crackle.git"
inherit git-r3
else
SRC_URI="http://lacklustre.net/projects/crackle/${P}.tgz"
KEYWORDS="~amd64 ~x86"
fi
LICENSE="BSD"
SLOT="0"
IUSE="test"
RESTRICT="!test? ( test )"
RDEPEND="net-libs/libpcap"
DEPEND="${RDEPEND}
test? ( dev-lang/perl )"
src_install() {
DESTDIR="${ED}" PREFIX=/usr emake install
}