You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-wireless/hostap-utils/hostap-utils-0.4.7-r1.ebuild

29 lines
608 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit toolchain-funcs
DESCRIPTION="Utilities for Intersil Prism2/2.5/3 based IEEE 802.11b wireless LAN products"
HOMEPAGE="https://hostap.epitest.fi/"
SRC_URI="https://hostap.epitest.fi/releases/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc x86"
PATCHES=( "${FILESDIR}/${P}-makefile.patch" )
src_compile() {
emake CC="$(tc-getCC)"
}
src_install() {
dosbin hostap_{crypt_conf,diag,fw_load,io_debug,rid}
dosbin prism2_{param,srec}
dosbin split_combined_hex
dodoc README
}