You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-wireless/kismet-rest/kismet-rest-2019.05.02.ebuild

28 lines
724 B

# Copyright 2019-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
PYTHON_COMPAT=( python3_{7,8,9} )
inherit distutils-r1
DESCRIPTION="Kismet REST Python API"
HOMEPAGE="https://kismetwireless.net/docs/devel/webui_rest/endpoints/"
if [ "${PV}" = "9999" ]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/kismetwireless/python-kismet-rest.git"
else
KEYWORDS="~amd64 ~x86"
SRC_URI="https://github.com/kismetwireless/python-kismet-rest/archive/${PV}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/python-${P}"
fi
LICENSE="GPL-2+"
SLOT="0"
IUSE=""
DEPEND="dev-python/requests
!<net-wireless/kismet-2019.05.1"
RDEPEND="${DEPEND}"
BDEPEND=""
REQUIRED_USE="${PYTHON_REQUIRED_USE}"