You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-wireless/soapy_power/soapy_power-9999.ebuild

31 lines
799 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
PYTHON_COMPAT=( python3_{7,8,9} )
inherit distutils-r1
DESCRIPTION="Obtain power spectrum from SoapySDR devices"
HOMEPAGE="https://github.com/xmikos/soapy_power"
LICENSE="MIT"
SLOT="0"
if [ "${PV}" = "9999" ]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/xmikos/soapy_power.git"
else
KEYWORDS="~amd64 ~x86"
SRC_URI="https://github.com/xmikos/soapy_power/archive/v${PV}.tar.gz -> ${P}.tar.gz"
fi
IUSE="faster +fastest"
DEPEND=""
RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]
dev-python/simplespectral[${PYTHON_USEDEP}]
>=dev-python/simplesoapy-1.5.0[${PYTHON_USEDEP}]
faster? ( dev-python/scipy[${PYTHON_USEDEP}] )
fastest? ( dev-python/pyFFTW[${PYTHON_USEDEP}] )"