You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-wireless/soapyrtlsdr/soapyrtlsdr-9999.ebuild

26 lines
624 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit cmake
DESCRIPTION="SoapySDR RTL-SDR Support Module"
HOMEPAGE="https://github.com/pothosware/SoapyRTLSDR"
if [ "${PV}" = "9999" ]; then
EGIT_REPO_URI="https://github.com/pothosware/SoapyRTLSDR.git"
inherit git-r3
else
KEYWORDS="~amd64 ~x86"
SRC_URI="https://github.com/pothosware/SoapyRTLSDR/archive/soapy-rtl-sdr-${PV}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}"/SoapyRTLSDR-soapy-rtl-sdr-"${PV}"
fi
LICENSE="MIT"
SLOT="0"
RDEPEND="net-wireless/soapysdr:=
net-wireless/rtl-sdr"
DEPEND="${RDEPEND}"