You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-wireless/soapysdr/soapysdr-0.7.2.ebuild

58 lines
1.3 KiB

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
PYTHON_COMPAT=( python3_{7,8,9} )
inherit cmake python-r1
DESCRIPTION="vendor and platform neutral SDR support library"
HOMEPAGE="https://github.com/pothosware/SoapySDR"
if [ "${PV}" = "9999" ]; then
EGIT_REPO_URI="https://github.com/pothosware/SoapySDR.git"
EGIT_CLONE_TYPE="shallow"
inherit git-r3
else
KEYWORDS="~amd64 ~x86"
SRC_URI="https://github.com/pothosware/SoapySDR/archive/soapy-sdr-${PV}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}"/SoapySDR-soapy-sdr-"${PV}"
fi
LICENSE="Boost-1.0"
SLOT="0/${PV}"
IUSE="bladerf hackrf python rtlsdr plutosdr uhd"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
RDEPEND="python? ( ${PYTHON_DEPS} )"
DEPEND="${RDEPEND}
python? ( dev-lang/swig:0 )
"
PDEPEND="bladerf? ( net-wireless/soapybladerf )
hackrf? ( net-wireless/soapyhackrf )
rtlsdr? ( net-wireless/soapyrtlsdr )
plutosdr? ( net-wireless/soapyplutosdr )
uhd? ( net-wireless/soapyuhd )"
src_configure() {
configuration() {
mycmakeargs+=(
-DENABLE_PYTHON=ON
-DBUILD_PYTHON3=ON
)
}
if use python; then
python_foreach_impl configuration
fi
cmake_src_configure
}
src_install() {
cmake_src_install
python_foreach_impl python_optimize
}