You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/ros-meta/navigation/navigation-1.17.0.ebuild

34 lines
680 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
ROS_REPO_URI="https://github.com/ros-planning/navigation"
KEYWORDS="~amd64 ~arm"
ROS_SUBDIR=${PN}
inherit ros-catkin
DESCRIPTION="2D navigation stack"
LICENSE="BSD LGPL-2.1"
SLOT="0"
IUSE=""
RDEPEND="
dev-ros/amcl
dev-ros/base_local_planner
dev-ros/carrot_planner
dev-ros/clear_costmap_recovery
dev-ros/costmap_2d
dev-ros/dwa_local_planner
dev-ros/fake_localization
dev-ros/global_planner
dev-ros/map_server
dev-ros/move_base
dev-ros/move_slow_and_clear
dev-ros/nav_core
dev-ros/navfn
dev-ros/rotate_recovery
dev-ros/voxel_grid
"
DEPEND="${RDEPEND}"