You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sci-astronomy/gasgano/gasgano-2.4.8.ebuild

43 lines
964 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit desktop java-pkg-2
PDOC=VLT-PRO-ESO-19000-1932-V4
DESCRIPTION="ESO astronomical data file organizer"
HOMEPAGE="http://www.eso.org/sci/software/gasgano/"
SRC_URI="ftp://ftp.eso.org/pub/dfs/${PN}/${P}.tar.gz
doc? ( http://www.eso.org/sci/software/gasgano/${PDOC}.pdf )"
LICENSE="Apache-1.1"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="doc"
DEPEND=">=virtual/jdk-1.8:*"
RDEPEND="
>=virtual/jre-1.8:*
dev-java/gnu-regexp
dev-java/junit
dev-java/jal"
src_prepare() {
default
sed -i \
-e "s:^BASE=\`pwd\`:BASE=${EPREFIX}/usr/share/${PN}:" \
-e 's:$BASE/share/:$BASE/lib/:g' \
bin/gasgano || die
}
src_install() {
dobin bin/*
java-pkg_dojar share/*.jar
insinto /usr/share/${PN}
doins -r config
make_desktop_entry gasgano "Gasgano FITS Organizer"
use doc && newdoc "${DISTDIR}"/${PDOC}.pdf user-manual.pdf
}