You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sci-astronomy/scamp/scamp-2.0.4.ebuild

52 lines
1.2 KiB

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
inherit autotools
DESCRIPTION="Astrometric and photometric solutions for astronomical images"
HOMEPAGE="http://www.astromatic.net/software/scamp"
SRC_URI="http://www.astromatic.net/download/${PN}/${P}.tar.gz"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
LICENSE="GPL-3"
SLOT="0"
IUSE="doc plplot threads"
RDEPEND="
sci-astronomy/cdsclient
sci-libs/atlas[lapack,threads=]
sci-libs/fftw:3.0
plplot? ( sci-libs/plplot:= )"
DEPEND="${RDEPEND}"
src_prepare() {
default
local mycblas=atlcblas myclapack=atlclapack
if use threads; then
[[ -e "${EPREFIX}"/usr/$(get_libdir)/libptcblas.so ]] && \
mycblas=ptcblas
[[ -e "${EPREFIX}"/usr/$(get_libdir)/libptclapack.so ]] && \
myclapack=ptclapack
fi
sed -e "s/-lcblas/-l${mycblas}/g" \
-e "s/AC_CHECK_LIB(cblas/AC_CHECK_LIB(${mycblas}/g" \
-e "s|lapack_lib=\"lapack\"|lapack_lib=${myclapack}|" \
-i acx_atlas.m4 || die
sed -e 's|plplotd|plplot|g' -i acx_plplot.m4 || die
eautoreconf
}
src_configure() {
econf \
--with-atlas-incdir="${EPREFIX}/usr/include/atlas" \
$(use_enable plplot) \
$(use_enable threads)
}
src_install() {
default
use doc && dodoc doc/*
}