You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sci-biology/muscle/muscle-3.8.31.ebuild

32 lines
580 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit toolchain-funcs
MY_P="${PN}${PV}_src"
DESCRIPTION="Multiple sequence comparison by log-expectation"
HOMEPAGE="http://www.drive5.com/muscle/"
SRC_URI="http://www.drive5.com/muscle/downloads${PV}/${MY_P}.tar.gz"
LICENSE="public-domain"
SLOT="0"
KEYWORDS="amd64 ppc x86"
RDEPEND="!sci-libs/libmuscle"
S="${WORKDIR}"/${PN}${PV}/src
PATCHES=( "${FILESDIR}"/${PV}-make.patch )
src_configure() {
tc-export CXX
}
src_install() {
dobin muscle
dodoc *.txt
}