You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sci-chemistry/pdbmat/pdbmat-3.89.ebuild

32 lines
649 B

# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
inherit cmake-utils fortran-2
DESCRIPTION="Calculate Tirion's model from pdb structures"
HOMEPAGE="http://ecole.modelisation.free.fr/modes.html"
SRC_URI="http://ecole.modelisation.free.fr/enm2011.tar.gz -> ${P}.tar.gz"
SLOT="0"
LICENSE="CeCILL-2"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="examples"
S="${WORKDIR}"/Source_ENM2011
src_prepare() {
cp "${FILESDIR}"/CMakeLists.txt . || die
cmake-utils_src_prepare
}
src_configure() {
local mycmakeargs=(
-DEXAMPLES=$(usex examples)
)
cmake-utils_src_configure
}