You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sci-chemistry/wxmacmolplt/wxmacmolplt-7.5-r1.ebuild

49 lines
986 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
WX_GTK_VER=3.0
inherit autotools desktop toolchain-funcs wxwidgets
DESCRIPTION="Chemical 3D graphics program with GAMESS input builder"
HOMEPAGE="http://www.scl.ameslab.gov/MacMolPlt/"
SRC_URI="https://wxmacmolplt.googlecode.com/files/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
RDEPEND="
media-libs/glew:0=
media-libs/mesa[X(+)]
x11-libs/wxGTK:${WX_GTK_VER}[X,opengl]"
DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"
PATCHES=( "${FILESDIR}"/${P}-glew.patch )
src_prepare() {
default
sed \
-e "/^dist_doc_DATA/d" \
-i Makefile.am || die "Failed to disable installation of LICENSE file"
eautoreconf
}
src_configure() {
tc-export PKG_CONFIG
setup-wxwidgets unicode
econf \
--with-glew \
--without-ming
}
src_install() {
default
doicon resources/${PN}.png
make_desktop_entry ${PN} wxMacMolPlt ${PN} "Science;DataVisualization;"
}