You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sci-electronics/irsim/irsim-9.7.93.ebuild

49 lines
1.1 KiB

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
inherit epatch multilib
DESCRIPTION="IRSIM is a \"switch-level\" simulator"
HOMEPAGE="http://opencircuitdesign.com/irsim/"
SRC_URI="http://opencircuitdesign.com/irsim/archive/${P}.tgz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
RDEPEND="dev-lang/tcl:0
dev-lang/tk:0"
DEPEND="${RDEPEND}
app-shells/tcsh"
src_prepare() {
epatch "${FILESDIR}"/${PN}-9.7.72-ldflags.patch
epatch "${FILESDIR}"/${PN}-9.7.79-datadir.patch
}
src_configure() {
# Short-circuit top-level configure script to retain CFLAGS
cd scripts
econf
}
src_install() {
emake DESTDIR="${D}" DOCDIR=/usr/share/doc/${PF} install
dodoc README
}
pkg_postinst() {
einfo
einfo "You will probably need to add to your ~/.Xdefaults"
einfo "the following line:"
einfo "irsim.background: black"
einfo
einfo "This is needed because Gentoo from default sets a"
einfo "grey background which makes impossible to see the"
einfo "simulation (white line on light gray background)."
einfo
}