You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sci-geosciences/congen/congen-1.6.2-r1.ebuild

34 lines
644 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
inherit ltprune
MY_P=${P/_p/-r}
DESCRIPTION="Calculate speeds, equilibrium arguments, node factors of tidal constituents"
HOMEPAGE="http://www.flaterco.com/xtide/files.html"
SRC_URI="ftp://ftp.flaterco.com/xtide/${MY_P}.tar.bz2"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE="static-libs"
DEPEND=">=sci-geosciences/libtcd-2.2.3"
RDEPEND="${DEPEND}"
MAKEOPTS+=" -j1"
S=${WORKDIR}/${P%_p*}
src_configure() {
econf \
$(use_enable static-libs static)
}
src_install() {
default
use static-libs || prune_libtool_files
}