You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sci-geosciences/geocode-glib/geocode-glib-3.26.2.ebuild

45 lines
1.1 KiB

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit gnome.org meson xdg
DESCRIPTION="GLib helper library for geocoding services"
HOMEPAGE="https://git.gnome.org/browse/geocode-glib"
LICENSE="LGPL-2+"
SLOT="0"
KEYWORDS="~alpha amd64 ~arm arm64 ~ia64 ~ppc ~ppc64 ~sparc x86"
IUSE="gtk-doc +introspection test"
RDEPEND="
>=dev-libs/glib-2.44:2
>=dev-libs/json-glib-0.99.2[introspection?]
>=net-libs/libsoup-2.42:2.4[introspection?]
introspection? ( >=dev-libs/gobject-introspection-1.54:= )
"
DEPEND="${RDEPEND}"
BDEPEND="
dev-util/glib-utils
gtk-doc? (
>=dev-util/gtk-doc-1.13
app-text/docbook-xml-dtd:4.3 )
>=sys-devel/gettext-0.19.8
virtual/pkgconfig
"
RESTRICT="!test? ( test )"
PATCHES=(
"${FILESDIR}"/disable-installed-tests.patch
)
src_configure() {
local emesonargs=(
$(meson_use test enable-installed-tests) # Actual installation to live system is sedded out, but we need this for running them in src_test
$(meson_use introspection enable-introspection)
$(meson_use gtk-doc enable-gtk-doc)
)
meson_src_configure
}