You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sci-geosciences/readosm/readosm-1.0.0e-r1.ebuild

30 lines
580 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
DESCRIPTION="Library to extract valid data from an Open Street Map input file"
HOMEPAGE="https://www.gaia-gis.it/fossil/readosm"
SRC_URI="https://www.gaia-gis.it/gaia-sins/${PN}-sources/${P}.tar.gz"
LICENSE="MPL-1.1"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="static-libs"
RDEPEND="
dev-libs/expat
sys-libs/zlib
"
DEPEND="${RDEPEND}"
src_configure() {
econf \
$(use_enable static-libs static)
}
src_install() {
default
find "${D}" -name '*.la' -delete || die
}