You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sci-libs/cdd+/cdd+-077a.ebuild

41 lines
852 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
inherit epatch multilib toolchain-funcs
DESCRIPTION="Another implementation of the double description method"
HOMEPAGE="http://www.ifor.math.ethz.ch/~fukuda/cdd_home/"
SRC_URI="ftp://ftp.ifor.math.ethz.ch/pub/fukuda/cdd/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~arm x86"
IUSE=""
DEPEND="dev-libs/gmp:0="
RDEPEND="${DEPEND}"
src_prepare() {
epatch \
"${FILESDIR}"/${P}-headers.patch \
"${FILESDIR}"/${P}-gentoo.patch \
"${FILESDIR}"/${P}-gcc-5.patch \
"${FILESDIR}"/${P}-qa-const-char.patch
}
src_compile() {
emake \
CC="$(tc-getCC)" \
LIBDIR="${EPREFIX}/usr/$(get_libdir)" \
GMPLIBDIR="${EPREFIX}/usr/$(get_libdir)" \
GMPINCLUDE="${EPREFIX}/usr/include" \
all
}
src_install() {
dobin cddr+ cddf+
}