You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sci-libs/libgenome/libgenome-1.3-r1.ebuild

40 lines
692 B

# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
inherit autotools
DESCRIPTION="Library for sci-biology/mauve"
HOMEPAGE="http://gel.ahabs.wisc.edu/mauve/"
SRC_URI="mirror://gentoo/${PF}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
IUSE="doc static-libs"
KEYWORDS="~amd64 ~x86"
DEPEND="doc? ( app-doc/doxygen )"
RDEPEND=""
PATCHES=( "${FILESDIR}/${PN}-1.3-fix-c++14.patch" )
src_prepare() {
default
rm libGenome/gnDefs.cpp || die
eautoreconf
}
src_configure() {
econf \
--enable-shared \
$(use_enable static-libs static)
}
src_install() {
default
# package provides .pc files
find "${D}" -name '*.la' -delete || die
}