You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sci-libs/libmuscle/libmuscle-3.7-r3.ebuild

41 lines
726 B

# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
inherit autotools
DESCRIPTION="Library for sci-biology/mauve"
HOMEPAGE="http://gel.ahabs.wisc.edu/mauve/"
SRC_URI="mirror://gentoo/${P}-r1.tar.bz2"
LICENSE="public-domain"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc static-libs"
RDEPEND="!sci-biology/muscle"
DEPEND="${RDEPEND}
doc? ( app-doc/doxygen )"
PATCHES=(
"${FILESDIR}"/${PV}-bufferoverflow.patch
"${FILESDIR}"/${PN}-3.7-fix-build-system.patch
)
src_prepare() {
default
eautoreconf
}
src_configure() {
econf $(use_enable static-libs static)
}
src_install() {
default
# package provides .pc file
find "${D}" -name '*.la' -delete || die
}