You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sci-libs/libpdb/libpdb-991112-r1.ebuild

46 lines
801 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
inherit toolchain-funcs
DESCRIPTION="PDB Record I/O Libraries -- c version"
HOMEPAGE="http://www.cgl.ucsf.edu/Overview/software.html"
SRC_URI="mirror://gentoo/${P}.shar"
SLOT="0"
LICENSE="BSD"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="static-libs"
RDEPEND=""
DEPEND="${RDEPEND}
app-arch/sharutils"
S="${WORKDIR}"
PATCHES=( "${FILESDIR}"/${P}-dynlib+flags.patch )
src_unpack() {
"${EPREFIX}/usr/bin/unshar" "${DISTDIR}"/${A} || die
}
src_prepare() {
default
tc-export CC RANLIB AR
}
src_compile() {
emake ${PN}.so
use static-libs && emake ${PN}.a
}
src_install() {
dolib.so ${PN}.so*
use static-libs && dolib.a ${PN}.a
insinto /usr/include/${PN}
doins *.h
}