You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sci-libs/libticonv/libticonv-1.1.5.ebuild

42 lines
805 B

# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
inherit autotools
DESCRIPTION="Charset conversion library for TI calculators"
HOMEPAGE="http://lpg.ticalc.org/prj_tilp/"
SRC_URI="mirror://sourceforge/tilp/tilp2-linux/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
IUSE="doc iconv static-libs"
RDEPEND="dev-libs/glib:2"
DEPEND="${RDEPEND}
virtual/pkgconfig"
DOCS=( AUTHORS LOGO NEWS README ChangeLog docs/api.txt )
src_prepare() {
default
eautoreconf
}
src_configure() {
econf \
$(use_enable static-libs static) \
$(use_enable iconv)
}
src_install() {
if use doc; then
HTML_DOCS=( docs/html/. )
DOCS+=( docs/charsets )
fi
default
find "${D}" -name '*.la' -delete || die
}