You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sci-libs/libtifiles2/libtifiles2-1.1.7.ebuild

46 lines
902 B

# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
inherit autotools
DESCRIPTION="Library for TI calculator files"
HOMEPAGE="http://lpg.ticalc.org/prj_tilp/"
SRC_URI="mirror://sourceforge/tilp/tilp2-linux/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
IUSE="doc nls static-libs"
RDEPEND="
app-arch/libarchive
dev-libs/glib:2
>=sci-libs/libticables2-1.3.3
>=sci-libs/libticonv-1.1.3
nls? ( virtual/libintl )"
DEPEND="${RDEPEND}
virtual/pkgconfig
nls? ( sys-devel/gettext )"
DOCS=( AUTHORS LOGO NEWS README ChangeLog docs/api.txt )
src_prepare() {
default
eautoreconf
}
src_configure() {
econf --disable-rpath \
$(use_enable static-libs static) \
$(use_enable nls)
}
src_install() {
use doc && HTML_DOCS=( docs/html/. )
default
find "${D}" -name '*.la' -delete || die
}