You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sci-libs/shapely/shapely-1.7.1.ebuild

40 lines
839 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
MY_PN="Shapely"
MY_P="${MY_PN}-${PV}"
PYTHON_COMPAT=( python3_{7..9} )
inherit distutils-r1
DESCRIPTION="Geometric objects, predicates, and operations"
HOMEPAGE="https://pypi.org/project/Shapely/ https://github.com/Toblerity/Shapely"
SRC_URI="https://github.com/Toblerity/Shapely/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 ~arm64 x86"
RDEPEND="
dev-python/numpy[${PYTHON_USEDEP}]
>=sci-libs/geos-3.3
"
BDEPEND="${RDEPEND}
dev-python/cython[${PYTHON_USEDEP}]
"
S="${WORKDIR}/${MY_P}"
distutils_enable_tests pytest
distutils_enable_sphinx docs dev-python/matplotlib
python_test() {
distutils_install_for_testing
${EPYTHON} -m pytest tests || die "tests failed under ${EPYTHON}"
}