You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sci-libs/sktime/sktime-0.4.2.ebuild

35 lines
754 B

# Copyright 2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
PYTHON_COMPAT=( python3_{7..9} )
DISTUTILS_IN_SOURCE_BUILD=1
inherit distutils-r1
DESCRIPTION="scikit-learn toolbox for working with time series"
HOMEPAGE="https://sktime.org"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64"
RDEPEND="
dev-python/numpy[${PYTHON_USEDEP}]
dev-python/pandas[${PYTHON_USEDEP}]
dev-python/statsmodels[${PYTHON_USEDEP}]
dev-python/wheel[${PYTHON_USEDEP}]
sci-libs/scikit-learn[${PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}"
python_compile() {
distutils-r1_python_compile bdist_egg egg_info bdist_wheel
}
python_install() {
distutils-r1_python_install
python_optimize
}