You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sci-libs/votca-tools/votca-tools-1.5.1.ebuild

57 lines
1.1 KiB

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
CMAKE_MAKEFILE_GENERATOR="ninja"
inherit cmake-utils multilib
if [ "${PV}" != "9999" ]; then
SRC_URI="https://github.com/${PN/-//}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86 ~amd64-linux"
S="${WORKDIR}/${P#votca-}"
else
inherit git-r3
EGIT_REPO_URI="https://github.com/${PN/-//}.git"
fi
DESCRIPTION="Votca tools library"
HOMEPAGE="http://www.votca.org"
LICENSE="Apache-2.0"
SLOT="0"
IUSE="doc +fftw sqlite"
RDEPEND="
dev-libs/boost:=
dev-libs/expat
>=dev-cpp/eigen-3.3
fftw? ( sci-libs/fftw:3.0 )
sqlite? ( dev-db/sqlite:3 )"
DEPEND="${RDEPEND}
doc? ( >=app-doc/doxygen-1.7.6.1[dot] )
>=app-text/txt2tags-2.5
virtual/pkgconfig"
DOCS=( NOTICE )
src_configure() {
mycmakeargs=(
-DWITH_FFTW=$(usex fftw)
-DWITH_SQLITE3=$(usex sqlite)
-DWITH_RC_FILES=OFF
)
cmake-utils_src_configure
}
src_install() {
cmake-utils_src_install
if use doc; then
cd "${CMAKE_BUILD_DIR}"
cmake-utils_src_make html
dodoc -r share/doc/html
fi
}