You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sci-mathematics/cvc4/cvc4-1.7-r1.ebuild

63 lines
1.3 KiB

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CMAKE_MAKEFILE_GENERATOR=emake
PYTHON_COMPAT=( python3_{7,8,9} )
inherit cmake python-any-r1
DESCRIPTION="Automatic theorem prover for satisfiability modulo theories (SMT) problems"
HOMEPAGE="https://cvc4.github.io/"
SRC_URI="https://github.com/CVC4/CVC4/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="+cln proofs readline replay +statistics"
RDEPEND="dev-libs/antlr-c
dev-java/antlr:3
dev-libs/boost
readline? ( sys-libs/readline:0= )
cln? ( sci-libs/cln )
!cln? ( dev-libs/gmp:= )"
DEPEND="${RDEPEND}"
BDEPEND="${PYTHON_DEPS}"
S="${WORKDIR}"/${P^^}
PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
src_configure() {
local mycmakeargs=(
-DANTLR_BINARY=/usr/bin/antlr3
-DENABLE_GPL=ON
-DENABLE_OPTIMIZED=ON
-DUSE_CLN="$(usex cln ON OFF)"
-DUSE_READLINE="$(usex readline ON OFF)"
-DENABLE_STATISTICS="$(usex statistics ON OFF)"
-DENABLE_PROOFS="$(usex proofs ON OFF)"
-DENABLE_REPLAY="$(usex replay ON OFF)"
)
cmake_src_configure
}
src_test() {
emake -C "${BUILD_DIR}" \
examples \
boilerplate \
ouroborous \
reset_assertions \
sep_log_api \
smt2_compliance \
two_smt_engines \
statistics
cmake_src_test
}
src_install() {
cmake_src_install
mv "${D}"/usr/{lib,$(get_libdir)}
}