You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sci-mathematics/fann/fann-2.2.0-r1.ebuild

39 lines
751 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
MY_P=FANN-${PV}-Source
inherit cmake
DESCRIPTION="Fast Artificial Neural Network Library"
HOMEPAGE="http://leenissen.dk/fann/wp/"
SRC_URI="mirror://sourceforge/${PN}/${MY_P}.zip"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE="examples"
RDEPEND=""
BDEPEND="app-arch/unzip"
S="${WORKDIR}/${MY_P}"
PATCHES=( "${FILESDIR}/${P}-examples.patch" )
src_test() {
cd examples || die
emake CFLAGS="${CFLAGS} -I../src/include -L${BUILD_DIR}/src"
LD_LIBRARY_PATH="${BUILD_DIR}/src" emake runtest
emake clean
}
src_install() {
cmake_src_install
if use examples; then
insinto /usr/share/doc/${PF}
doins -r examples
fi
}