You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sci-mathematics/prng/prng-3.0.2-r2.ebuild

43 lines
851 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
inherit autotools
DESCRIPTION="Pseudo-Random Number Generator library"
HOMEPAGE="http://statmath.wu.ac.at/prng/"
SRC_URI="http://statmath.wu.ac.at/prng/${P}.tar.gz"
LICENSE="GPL-2"
SLOT=0
KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
IUSE="doc examples static-libs"
PATCHES=(
"${FILESDIR}"/${PN}-3.0.2-shared.patch
"${FILESDIR}"/${PN}-3.0.2-fix-c99-inline-semantics.patch
)
src_prepare() {
default
eautoreconf
}
src_configure() {
econf $(use_enable static-libs static)
}
src_install() {
default
use doc && dodoc doc/${PN}.pdf
if use examples; then
rm examples/Makefile* || die
dodoc -r examples
docompress -x /usr/share/doc/${PF}/examples
fi
if ! use static-libs; then
find "${D}" -name '*.la' -delete || die
fi
}