You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sci-mathematics/rkward/rkward-0.7.2.ebuild

55 lines
1.2 KiB

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
ECM_HANDBOOK="forceoptional"
inherit ecm kde.org optfeature
DESCRIPTION="IDE for the R-project"
HOMEPAGE="https://rkward.kde.org/"
if [[ ${KDE_BUILD_TYPE} = release ]]; then
SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${P}.tar.gz"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
fi
LICENSE="GPL-2+ LGPL-2"
SLOT="5"
IUSE=""
BDEPEND="
sys-devel/gettext
"
DEPEND="
dev-lang/R
dev-qt/qtgui:5
dev-qt/qtnetwork:5
dev-qt/qtprintsupport:5
dev-qt/qtscript:5
dev-qt/qtwebengine:5[widgets]
dev-qt/qtwidgets:5
dev-qt/qtxml:5
kde-frameworks/kcompletion:5
kde-frameworks/kconfig:5
kde-frameworks/kconfigwidgets:5
kde-frameworks/kcoreaddons:5
kde-frameworks/kcrash:5
kde-frameworks/ki18n:5
kde-frameworks/kio:5
kde-frameworks/kjobwidgets:5
kde-frameworks/knotifications:5
kde-frameworks/kparts:5
kde-frameworks/kservice:5
kde-frameworks/ktexteditor:5
kde-frameworks/kwidgetsaddons:5
kde-frameworks/kwindowsystem:5
kde-frameworks/kxmlgui:5
"
RDEPEND="${DEPEND}"
pkg_postinst() {
optfeature "kate plugins support" kde-apps/kate:${SLOT}
ecm_pkg_postinst
}