You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sci-misc/flashdot/flashdot-1.1.4-r1.ebuild

37 lines
788 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
DESCRIPTION="Generator for psychophysical experiments"
HOMEPAGE="http://www.flashdot.info/"
SRC_URI="mirror://gentoo/${P}.tar.bz2
https://dev.gentoo.org/~tomka/files/${P}.tar.bz2"
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="~amd64 ~x86"
IUSE="+ocamlopt"
DEPEND="
>=dev-lang/ocaml-3.10[ocamlopt?]
dev-ml/gsl-ocaml
dev-ml/lablgl[glut]
dev-ml/ocamlsdl
x11-apps/xdpyinfo"
RDEPEND="${DEPEND}"
PATCHES=(
"${FILESDIR}/${P}-gsl-ocaml.patch"
"${FILESDIR}"/${P}-ocaml-4.09.patch
)
src_prepare() {
default
MAKEOPTS+=" -j1 VERSION=${PV}"
use ocamlopt || MAKEOPTS+=" TARGETS=flashdot_bytecode BYTECODENAME=flashdot"
}
src_install() {
emake DESTDIR="${D}" CALLMODE=script install
}