You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sci-misc/ncview/ncview-2.1.7.ebuild

36 lines
690 B

# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
inherit eutils
DESCRIPTION="X-based viewer for netCDF files"
HOMEPAGE="http://meteora.ucsd.edu/~pierce/ncview_home_page.html"
SRC_URI="ftp://cirrus.ucsd.edu/pub/ncview/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
IUSE=""
KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
RDEPEND="media-libs/libpng:0=
>=sci-libs/netcdf-4.1[hdf5]
x11-libs/libXaw
sci-libs/udunits"
DEPEND="${RDEPEND}"
src_install() {
default
doman data/${PN}.1
insinto /usr/share/X11/app-defaults
newins Ncview-appdefaults Ncview
insinto /usr/share/${PN}
doins *.ncmap
make_desktop_entry ${PN}
}